Ubiquity vs Cisco

Early on in the DBIUA we didn’t have much money, and had to be pretty frugal in what equipment we used.

Someone else told me early on, pick a radio vendor and stay with them.  Don’t mix and match.  We decided early on to use Ubiquity radios.  They had a wide range of options in their AirMax line, and the prices were very affordable.

To this date, I don’t regret making this choice, the radio’s have worked extremely well, and have been easy to setup.

We also decided to stick with the Ubiquity brand for other network equipment, including their 5 port tough switch, as well as their Edge Router and Edge Switch.

The 5 port tough switch is great, and we use these at all our remote relay stations.

The Edge Router though we had some problems with.  A few months back we started noticing that large downloads would just die mid download due to “packet errors”.  Sometimes if you tried again it would go through fine.

Doing a little googling it seems that others were having problems when they were going through an Edge Router.  I made sure we were updated to the latest firmware, and then I did some tests where I tried the download behind the Router, and then again in front of the router.

Behind the router I could get the download to fail every time.  In front of the router worked no problem.  So, it wasn’t a problem upstream.

So, the solution (now that we had some more money in the bank), was to upgrade to a Cisco 1900 router.

This was not nearly as plug and play to setup as the Edge Router was, and required some serious googling around to get NAT working correctly, and the failover to work across our primary and backup link, but eventually I got it configured correctly and we were back in business with no errors on large downloads.

Plus, as one of our members Brett Marl says “will be much more bomber with cisco hardware in the shed”.

For those who are interested, here is our cisco config, with NAT setup for our 10.0.0.0 network, and failover to our backup link.

interface GigabitEthernet0/0
 description primary link isp1
 ip address aaa.aaa.aaa.aaa 255.255.255.248
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description secondary link isp2
 ip address bbb.bbb.bbb.bbb 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 no ip address
!
interface GigabitEthernet0/0/1
 no ip address
!
interface GigabitEthernet0/0/2
 no ip address
!
interface GigabitEthernet0/0/3
 no ip address
!
interface Vlan1
 description inside LAN segment
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip nat inside source route-map isp1 interface GigabitEthernet0/0 overload
ip nat inside source route-map isp2 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 aaa.aaa.aaa.aaa
ip route 0.0.0.0 0.0.0.0 bbb.bbb.bbb.bbb 10
!
!
route-map isp2 permit 10
 match ip address 100
 match interface GigabitEthernet0/1
!
route-map isp1 permit 10
 match ip address 100
 match interface GigabitEthernet0/0